Bersa Pistol Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My Thunder .380 fires double action only (DAO). This problem comes and goes. While it is active, the hammer cannot be latched by cocking the hammer by thumb, racking the slide, or by firing the pistol. A gunsmith repaired this a few years ago, but now the problem has returned. The pistol is kept clean and lightly oiled, has fired perhaps 500 rds., and is in perfect shape. The problem occurs with any type of ammunition. Sometimes while I am shooting, the problem goes away. Any advice for me?
 

·
Registered
Joined
·
2 Posts
I would check how tight your grips are sometimes they will bind the linkage ( if that is the term) l know it may sound too easy but it just might work. But don't forget to use blue loctite. Let me know if that works. Good luck I'm sure you will see what I mean!

Sent from my LG-P769 using Tapatalk
 

·
Registered
Joined
·
240 Posts
I would check how tight your grips are sometimes they will bind the linkage ( if that is the term) l know it may sound too easy but it just might work. But don't forget to use blue loctite. Let me know if that works. Good luck I'm sure you will see what I mean!

Sent from my LG-P769 using Tapatalk
I think that is a good start. Could be something simple. (Isn't it always? :mad:) Then I might ask that gunsmith what he did and if he or YOU could do it again.
 

·
Premium Member
Joined
·
1,043 Posts
My Thunder .380 fires double action only (DAO). This problem comes and goes. While it is active, the hammer cannot be latched by cocking the hammer by thumb, racking the slide, or by firing the pistol. A gunsmith repaired this a few years ago, but now the problem has returned. The pistol is kept clean and lightly oiled, has fired perhaps 500 rds., and is in perfect shape. The problem occurs with any type of ammunition. Sometimes while I am shooting, the problem goes away. Any advice for me?

Welcome to the Bersa Pistol Forum from the Lone Star State.

cowboy.gif
 

·
Registered
Joined
·
3 Posts
correction

A friend of mine ask me to look at his Bersa Thunder cc with a similar issue. It is a new gun with only one box of 380 put thru it. It would fire in DA but with the subsequent trigger pull in SA , it failed to fire and would only dimple the primer. NOTE: This did not happen everytime only intermediately. Pull the trigger again in DA and it will fire. Any suggestions on what to check first, would be appreciated.
 
1 - 5 of 5 Posts
Top